Java version needed for Brocade

Robert Leong -

Must use an older version of Java to work with Brocade web interface

Java 6 update 25 is required, works on Microsoft's Internet Explorer or ?, not Google Chrome.

This article applies to Windows only, tested on Windows 7 and Brocade 6510.

What version of Java do you have

 Uninstall Java

Older versions of Java may appear in the program list as J2SE, Java 2, Java SE or Java Runtime Environment.

Windows 7 and Vista - Uninstall Programs
    1. Click Start
    2. Select Control Panel
    3. Select Programs
    4. Click Programs and Features
    5. Select the program you want to uninstall by clicking on it, and then click the Uninstall button.

You may need administrator privileges to remove programs.

 Download and install 6u25

Excerpt from

Re: Java plugin needed message when connecting to switch
‎04-01-2014 09:17 AM - edited ‎04-01-2014 09:18 AM
Remove all java version and install the version 6 update 25. Done Smiley Happy

Do not update Java

When connecting to the switch Internet Explore will likely report that Java needs to be updated, do not update it as this will un-do what had been done above, but instead right click the message and select "Run this time" or something similar to it.

Multiple Javas - to do

By deleting all newer versions of Java and installing an older one could break some other apps requiring newer Java.  Further testing will need to be done to see if multiple version can co-exist and selected by Java Control Panel.


Have more questions? Submit a request


Article is closed for comments.