StorNext vs OS update compatibility matrix

Robert Leong -

Scope

StorNext MDS (MDC) with rpm (FS) only installs

Purpose

  • To determine if a given OS version is compatible with a given StorNext version
  • To determine if a StorNext upgrade would require any intermediate upgrades

Example

Upgrading StorNext 4.2.2 to 4.7.2 requires an intermediate upgrade to 4.3.2.  

This intermediate step is per Quantum documentation, intermediate upgrade is needed due to the database (DB) change. However DB is only used with Storage Manager and FS only (rpm installs) does not. Therefore FS only (rpm installs) can be updated directly without intermediate versions, but if you want to be safe do the intermediate also.

 

As of
Jan 2017
Meta Data Server OS      
StorNext RHEL 5 RHEL 6 RHEL 7 SLES 10 SLES 11 SLES 12 DB License version Offical min level to upgrade from (FS only) *
5.4.0.3 no 6.7 7.0 - 7.2 no 11.2 - 11.4 12.0 - 12.1      
5.3.1 no 6.1 - 6.7 7.0 - 7.1   11.2 - 11.4 no     4.1.x
5.3.0 no 6.0 - 6.6 7.0 - 7.1   11.0 - 11.4 no      
5.2.2 5.4 - 5.10 6.0 - 6.6 no   11.0 - 11.3 no      
5.2.1 5.4 - 5.10 6.0 - 6.6 no   11.0 - 11.3 no MySQL   4.1.x
5.2.0 5.4 - 5.10 6.0 - 6.5 no  no 11.0 - 11.3  no MySQL    
5.0 5.4 - 5.10 6.0 - 6.6 no  no 11.0 - 11.3 12 MySQL Version 5 license required here and above?  4.1.x
4.7.3 5.4 - 5.7 6.0 - 6.7 no 10.3 - 10.4 11.0 - 11.3   no  MySQL   4.3.2
4.7.2 5.4 - 5.9 6.0 - 6.5   10.3 - 10.4 11.0 - 11.2   MySQL   4.3.2
4.7.1             MySQL    
4.7.0.1             MySQL    
4.7 5.4 - 5.9 6.0 - 6.4   10.3 - 10.4 11.0 - 11.2   MySQL   4.3.2
4.3.3 5.4 - 5.9 6.0 - 6.3   10.3 - 10.4 11.0 - 11.2   MySQL   4.1.x
4.3.2 5.4 - 5.8 6.0 - 6.3   10.3 - 10.4 11.0 - 11.2   MySQL   4.1.x
4.3 5.4 - 5.8 6.0 - 6.2   10.3 - 10.4 11.0 - 11.1   MySQL   4.1.x
4.2.2 5.1 - 5.7 6.0 - 6.2   10.1 - 10.4 11.0 - 11.1   Linter   4.1.x
4.2.1             Linter   4.1.x
4.2             Linter   4.1.x
4.1.3             Linter    
4.1.2 5.1 - 5.6     10.1 - 10.3 11.0 - 11.1   Linter   3.1.2 or 3.5.0
4.1.1             Linter   3.1.2 or 3.5.0
4.1.0             Linter    
4.0.1.1             Linter Version 4 license required here and above 3.1.2 or 3.5.0
3.5.3                  
3.5.2 5.1 - 5.4     10.1 - 10.3 11.0        
3.5.1                  
3.5.0                  
3.1.2                  
2.8.1                  
                   
* This intermediate step is per Quantum documentation, intermediate upgrade is needed due to the database (DB) change. However DB is only used with Storage Manager, filesystem only (rpm installs) does not. Therefore rpm installs can be updated directly without intermediate versions, but if you want to be safe do the intermediate also.

..

Have more questions? Submit a request

0 Comments

Article is closed for comments.